Is Windows Live Writer failing to display your blog theme correctly?

Yesterday I changed my WordPress blog theme to use the K2 design. Diligently I asked windows live writer to ‘please go get this new style’ and ended up with some rather pleasant but unasked for Times New Roman in the edit pane.

WatiN supports Firefox! - Windows Live Writer

The preview pane also didn’t look anything like my blog, obviously the style sheet reference was missing. Graphics and content appeared, just no styling.

WatiN supports Firefox! - Windows Live Writer (2)

I fired up ol-procmon to find out where an earth wlw was downloading the templates too.

\Users\[user name]\AppData\Roaming
\Windows Live Writer\blogtemplates

\Guid (Each blog ?) *1
\Guid 1 (For edit) \Guid 2 (For preview)

This is on Vista and Windows Server 2008, I imagine it’s different on other OS’s.

*1In this folder you will find 2 index[*].htm files which represent your edit and preview panes. Once I found these html files it turns out wlw had download the k2 css file ‘core.css.php’ as ‘core.css.css’. Renaming fixed my problem, yay!

About these ads
Tagged , , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: